Fix examples and update componentize-py to 0.24.0
This commit is contained in:
parent
7b8fbddcaf
commit
1b3be6f82f
@ -25,6 +25,7 @@ class MyPlugin(Plugin):
|
||||
authors=["you"],
|
||||
description="An example python plugin.",
|
||||
dependencies=[],
|
||||
permissions=[]
|
||||
)
|
||||
|
||||
def on_load(self, ctx: context.Context) -> None:
|
||||
|
||||
@ -22,6 +22,7 @@ class MyPlugin(Plugin):
|
||||
authors=["you"],
|
||||
description="An example python plugin.",
|
||||
dependencies=[],
|
||||
permissions=[],
|
||||
)
|
||||
|
||||
def on_load(self, ctx: context.Context) -> None:
|
||||
|
||||
@ -5,7 +5,7 @@ description = "Pumpkin plugin API for Python"
|
||||
authors = [{name = "alex"}]
|
||||
license = "GPL-3.0-only"
|
||||
dependencies = [
|
||||
"componentize-py>=0.22.1",
|
||||
"componentize-py>=0.24.0",
|
||||
]
|
||||
readme = "README.md"
|
||||
requires-python = ">=3.9"
|
||||
@ -14,7 +14,7 @@ requires-python = ">=3.9"
|
||||
pumpkin-plugin-build = "pumpkin_api.build:main"
|
||||
|
||||
[build-system]
|
||||
requires = ["hatchling","componentize-py>=0.22.1"]
|
||||
requires = ["hatchling","componentize-py>=0.24.0"]
|
||||
build-backend = "hatchling.build"
|
||||
|
||||
[tool.hatch.build.targets.sdist]
|
||||
|
||||
@ -60,6 +60,7 @@ def main():
|
||||
import_interface_names=[],
|
||||
export_interface_names=[],
|
||||
full_names=False,
|
||||
intersect_world=None,
|
||||
)
|
||||
|
||||
|
||||
|
||||
Loading…
Reference in New Issue
Block a user